Talk:DvorakMUSH

From Dvorak - A Blank-Card Game
Jump to: navigation, search

Vault

What's with CashCrazed's Vault? My friend and I got stuck in there, and now we can't get out! Nothing works, period. --Olly 15:47, 28 October 2009 (UTC)

Link

Um shouldn't "click this link" have a link attached? -Ryan1729

Oh, yes. Fixed. --Kevan 14:46, 6 March 2007 (UTC)

Exiled?

Has my character been permanently exiled? I played around with the building, created a new room for myself, then teleported into it and made it my home. Now I can't seem to teleport back, reset my home to the first room, or link an exit in my room to the original ones. CashCrazed 23:10, 31 March 2007 (BST)

Linking exits to other people's rooms might be disallowed by default, and something I didn't think to unlock for the base rooms; I'm a bit rusty on how MUSHes work. @tel #6 should work, though, to get you back to the Dvorak Lounge. --Kevan 16:14, 1 April 2007 (BST)
I can't teleport into other people's rooms, so all I get is "You can't teleport there!". It's odd that player's homes start in room #1, but you can't reset your home to that room if you move it. Is the ABODE flag set on that room? CashCrazed 20:41, 1 April 2007 (BST)
I can't remember what abode flags are. I've set the Dvorak Lounge as jump_ok, though, now, so you should be able to teleport to it. --Kevan 21:01, 1 April 2007 (BST)
All right, I'm back in now. Thanks! CashCrazed 23:17, 1 April 2007 (BST)

Security flaw

There's a security flaw in the game. At any time, any player can quietly use loadcard to palm cards into the deck without anyone knowing.-Bucky 23:51, 3 April 2007 (BST)

Fatal error

I was playing with structures and I think I broke something. I got some fatal error and it said the database had to reset. After that, the changes I made in the last 15 minutes were gone. I was the only one on, so I don't think anyone else was affected. CashCrazed 07:02, 4 April 2007 (BST)

Cleardeck bug

The cleardeck function doesn't quite work properly. After clearing the deck, there is still one card in the draw pile.-Bucky 23:10, 10 April 2007 (BST)

Feature Requests

1) Support for "Look at the top X cards of the deck [and rearrange them]"-Bucky

You can draw X cards to look at them, but there needs to be a way to place a card on top of the draw pile. Of course, if you don't have the option of rearranging them, then a look-at function would be better. MagiMaster 03:22, 26 March 2007 (BST)
Afraid all this is impossible, under the current implementation - the Engine doesn't store the order of the draw pile, it just gives you a random card from it, whenever you draw. You could work around it by just keeping the cards in your hand, and remembering that they're in a certain order on top of the draw pile, whenever anyone draws a card. --Kevan 11:05, 26 March 2007 (BST)
If anyone tries to update the Dvorak Engine, it shouldn't be too hard to add a 'Top of Draw Pile' location. Lookat would move cards from the unordered draw pile to the ordered top-of pile. (Unless I'm misunderstanding something anyway.) MagiMaster 00:04, 11 April 2007 (BST)

2) Support for large decks

I'm not sure how much this is a limitation of the TinyMUSH language, but I'll take a look at some point. (My MUSHcode is very, very rusty, though; the Dvorak Engine was the last thing I wrote in it, seven years ago. So I'll need quite a run-up.) --Kevan 11:05, 26 March 2007 (BST)
I think I finally found the culprit. The engine parameter "function_invocation_limit" limits the number of function calls in a command, and since the number of functions called scales with the number of cards in several commands, it also limits the size of the deck. Can you do anything about this limit? --CashCrazed 10:25, 3 January 2009 (UTC)

3) Directions on how to run multi-deck Dvorak -Bucky

AFAIK, the current version of the Dvorak Engine doesn't support multi-deck games. MagiMaster 03:22, 26 March 2007 (BST)
Correct. I thought it said that somewhere, but it doesn't. --Kevan 11:05, 26 March 2007 (BST)

4)Support for complex card types, such as "Thing-Wealth". Currently, there is no way to tell a Thing-Wealth from a Thing-Location.-Bucky

5)Support for colored cards -Bucky

6)Turn handling. Like, you type "done", and it says "Player has finished his turn", as well as a function to randomly assign who goes first. Adding this to the code might do it, but I don't know if the code is right since I can't test it. CashCrazed 07:29, 4 April 2007 (BST)

&DONE Dvorak Engine=$done:@emit [name(%#)] is finished with %p turn.
&TURNORDER Dvorak Engine=$turnorder:@pemit %#=[switch(u(order),,No turn order set.,Turn Order: [u(order)])]
&CLEARORDER Dvorak Engine=$clearorder:&order me;@emit [name(%#)] clears the turn order.
&NEWORDER Dvorak Engine=$neworder:&order me=shuffle(istrue(name(lwho()),nearby(me,##)), , -> );@emit [name(%#)] resets the turn order.%rNew Turn Order: [u(order)]
The Dvorak Engine source is available - you can create a copy of the object in your own private rooms, if you want to test out possible additions. --Kevan 09:45, 4 April 2007 (BST)
Will do. By the way, what is the purpose of this command?
&MOVECARD Dvorak Engine=$submovecard * *:&card%0 #7753=%1~[extract([u(card%0)],2,1,~)]~[extract([u(card%0)],3,1,~)]~[extract([u(card%0)],4,1,~)]
It doesn't work currently because there's no object #7753, but all this looks like to me is an undocumented command that lets you cheat by moving cards to diferent positions without anybody knowing. Shame, shame, shame... CashCrazed 21:25, 6 April 2007 (BST)
It's been seven years, I've no idea; either placeholder code for an unfinished function, or a quick one-off command that someone needed for a particular game. --Kevan 10:10, 10 April 2007 (BST)

7)A command to shuffle only the draw pile, rather than the draw and discard piles together. I may dive into MUSHcode and take a look at this myself, but I thought I'd mention it here nonetheless. --CK 01:23, 9 September 2007 (BST)

Command Problem

I typed in the command to create an account, but it didn't create it! Is there something else (along the lines of press enter) I have to do?--Nm8r 00:18, 5 April 2007 (BST)

Yes, you have to press enter. --Kevan 10:26, 5 April 2007 (BST)
Sorry, but pressing enter was the first thing I tried, and all it did was take me to the start of what I had typed and turned on insert.--Nm8r 13:04, 5 April 2007 (BST)
What operating system are you using? If you're running Windows, a dedicated MUSH client would be better than the default Windows telnet - SimpleMU is alright, I don't know if anyone can recommend a better one. --Kevan 18:39, 5 April 2007 (BST)
I had this problem at first with HyperTerminal. You need to set "Send line ends with line feeds.". It's somewhere in the properties under "ASCII Setup." CashCrazed 22:29, 6 April 2007 (BST)

I am having a problem with that, too. I can't create a account. I type create <*myUsername*> <*myPassword*> enter and it says that that username is either already taken or illegal. I then tried just random letters no one would use as a user name, and it still didn't work. I have the MUSHclient, and it still doesn't work. I haven't tried the "Send line ends with line feeds." thing,though. i'll try that. --Enimue

Are you putting <>s around the name? The proper command, if your name is 'name' and your password is 'password', would be:
create name password
-- Zaratustra 08:07, 6 March 2008 (UTC)

Names

What are the guidelines for usernames in DvorakMUSH?--Nm8r 15:39, 5 August 2007 (BST) Scratch that, It turns out that I was just typinng the command wrong.--Nm8r 15:42, 5 August 2007 (BST)

Dvorax

I'm currently developing a heavily modified version of the Dvorak Engine. It's called Dvorax, and right now it solves every feature request except possibly large or multiple decks. Problem is, commanding it eats up my tokens at an unbearable rate. Is there a way to set that object so it doesn't cost tokens to run commands? Right now it's object #351. -- CashCrazed 08:18, 13 April 2008 (BST)

Set it VISUAL so we can see its inner workings. - Zaratustra 19:16, 13 April 2008 (BST)
Alright, but it's not a pretty sight (the code is twice as convoluted as Kevan's, and less documented). Not to mention it lets you see everyone's cards. --CashCrazed 02:23, 14 April 2008 (BST)
The only way for it to not eat up tokens is for Kevan to set it not to I believe. (I'll research this some more, I've just started up my own mush.)
Also, how do you edit the export pages? Dvorax requires an ANSI color substitution appended to the start of the name, corner value appended to the end of the name in square brackets, and the full text rather than just one letter for the type (like "Thing - Weapon" or "Action - Surprise"). The description is the same as it always was. --CashCrazed 10:16, 13 April 2008 (BST)
Okay, never mind the square brackets, they don't work, but angled ones do. But now I have another problem. Some of my functions use deep nesting loops, and I get a "function invocation limit exceeded" error when using a real deck. Is there a way to increase that limit? --CashCrazed 11:15, 13 April 2008 (BST)

And several months later, working on Dvorax, my problem resurfaces. Here's what I found in the MUSH manual.
& function_invocation_limit
Config directive: function_invocation_limit <num>.  Default: 2500
 
This directive sets the maximum number of times that a command may make function calls.
If the invocation limit is exceeded, the string '#-1 FUNCTION INVOCATION LIMIT EXCEEDED'
is returned.  This limit is intended to prevent long hangs from creative uses of u() and iter().

The mechanics of the Dvorak Engine (and thus my derivative, Dvorax) rely on the creative use of u() and iter(). Increasing or eliminating this limit will allow much larger decks to function properly in either engine. --CashCrazed 10:20, 3 January 2009 (UTC)

No Cards In Deck

I used the Dvorak Source on a Pennmush but it always says: No cards in deck...

I used code to load deck from this site. Quinnr 19:39, 14 May 2008 (BST)

You probably need to set it to accept commands. Just say @set Dvorak Engine = commands, or @set Dvorak Engine=!no_command --Atticus 23:40, 19 May 2008 (BST)

I did it, but it always comes up with, no cards in play, no cards in deck, no cards in disc. When I load cards they are somewhere in logcards, and I can givecard to myself into my hand, but after playing it disappears again into logcards.

Telnet Client

Having gained a laptop running Windows instead of Mac, I need a telnet client to continue using the MUSH, and my computer does not have a default. Does anyone have any recommendations? --Atticus 23:41, 19 May 2008 (BST)

There are a couple listed on the page - if you just want a basic telnet client, I'd recommend PuTTY. --Kevan 17:10, 27 May 2008 (BST)

Server Down

Looks like dvorakgame.co.uk port 6250 is offline, or it just a firewall problem on my side? -- JoshuaW

It's not just you: I can't access it either. --Atticus 00:28, 21 July 2008 (BST)

Seems like it didn't come back up after a server crash. I've restarted it. --Kevan 23:15, 21 July 2008 (BST)

As of the time of post, the server is down again. --Atticus 23:19, 5 August 2008 (BST)

Restored. --Kevan 13:24, 6 August 2008 (BST)

Server seems to be down again as of time of post. Recon 18:34, 2 September 2008 (BST)

Got it. My server's been a bit shaky lately. --Kevan 19:59, 2 September 2008 (BST)

I think its down again Quinnr 19:30, 20 April 2009 (BST)

Back. Had been doing some heavy work on the server config earlier, must have cut through a cable without realising. --Kevan 00:48, 21 April 2009 (BST)
It'd been down for a long time - at least a week.-Bucky 01:09, 21 April 2009 (BST)
Its still down for me? Quinnr 04:10, 21 April 2009 (BST)
Maybe I cut through that cable last week as well. I guess I should set up something to alert me automatically.
The MUSH seems fine this morning. --Kevan 10:09, 21 April 2009 (BST)
Never mind, I had the wrong port number. --Quinnr 23:23, 21 April 2009 (BST)

This is what I get on a "telnet dvorakgame.co.uk 6250"

Trying 94.76.229.209...
telnet: Unable to connect to remote host: Connection refused

It's been like this for some days, is the server down? --Ferk 12:37, 29 December 2009 (UTC)

It's back up now. --Kevan 10:56, 5 January 2010 (UTC)

PuTTYtel problems

I can't seem to connect to the MUSH using PuTTYtel. I put "dvorakgame.co.uk" as the host name, and "6250" as the port number, but when I click open a console window pops up for a bit and then PuTTYtel shuts down; The console window is gone.—The preceding unsigned comment was added by Morning of the logicians (talkcontribs).

Rebooted. --Kevan 21:59, 30 April 2011 (UTC)

Down again

I believe the MUSH is down again. Luigi-Wan Kenobi 22:37, 26 June 2011 (UTC)

Seems fine from here, and I haven't had to restart it or anything. --Kevan 16:07, 28 June 2011 (UTC)

I'm sorry guys

Sorry guys...I guess I just had a moment of unwarranted hubris 2 years ago.....Let's face it....I tried to usurp Kevan's wizard power by hacking his original Dvorak machine...so that I could gain as many credits as I wanted and make my own Dvorak machine...but dammit....that wasn't right, and I'm sorry :(

just looking back on this site now.....I love the Dvorak game framework Kevan has created, and I should have just ASKED for the MUSH privileges instead of HACKING to acquire them....probably then I could have done much more for the MUSH. Even when I knew the MUSH had limitations I couldn't negotiate without him changing the MUSH parameters, I was just too damn PROUD to ask him DIRECTLY to increase them to allow me to continue my programming. And you know, maybe that's okay, because I think I remember a superior programmer trying to do what I did for the MUSH...but BETTER....and in the constraints the mush ALREADY HAS.. I haven't checked the MUSH in a while...maybe he HAS implemented his Dvorak solution...if he has, I salute him :)

I made a game engine a while back called Dvorax...it wasn't optimized...or anything..it worked for small decks....and only because of that did I ask for MUSH parameter extensions....but the other guy...did HIS with much LESS than me...for that I salute him....I think his name was...Zarasustra?

no matter...if he has taken over the the Dvorak MUSH...god speed dude :)